Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1706    Accepted Submission(s): 807
 

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
 
1 4 abab
 

 

Sample Output
 
6

#include <stdio.h>

#include <string.h>
#include <stdlib.h>
int
n,m,dp[300000],next[300000];
char
s[300000];
void
get_next()
{
     int
i=0,j=-1;
     next[0]=-1;
     while
(i<m)
     {
            if
(j==-1||s[i]==s[j])
            {
                     i++;
                     j++;
                     next[i]=j;
            }
            else
                j=next[j];
     }
}
int
main()
{
    scanf("%d",&n);
    while
(n--)
    {
              int
sum=0;
              scanf("%d",&m);
              scanf("%s",s);
              get_next();
              memset(dp,0,sizeof(dp));
              for
(int i=1;i<=m;++i)
              {
                    dp[i]=(dp[next[i]]+1)%10007;
                    sum=(sum+dp[i])%10007;
              }
              printf("%d\n",sum);
    }
}
ps:看别人的代码,原来自己dp很不熟,加油努力!